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Practical 12. Using Digimap to access OS data products

Aims:  This practical is designed to:

1. Introduce you to the EDINA Digimap online service for accessing Ordnance Survey digital map data products; and

2. Introduce you to the ESRI’s MapManager software for converting Digimap NTF format files into ArcGIS readable data

Objectives:  The steps involved in this practical are as follows:

1. Run the Digimap demo on the ISS desktop;

2. Use Digimap to download Landform Panorama 50m resolution DEM raster data and Meridian2 vector data for an area of your choice;

3. Use MapManager to convert the Digimap NTF format files to ArcGIS readable formats; and

4. Display in ArcMap and print.

Assignment 6:  The map that you produce for this practical will form the basis of your first assessment for this second part of the module (see separate handout for further details).
Introduction to Digimap

The EDINA Digimap service is extremely useful as a source of maps and data.  Principally, you will be using Digimap to download Ordnance Survey (OS) digital map data.  OS data products included on Digimap include:

· 1:10,000 scale Land.Line.Plus maps (street level vector data)

· 1:50,000 scale Landform Panorama DEMs and Contour lines

· 1:50,000 scale colour raster images of LandRanger maps

· 1:50,000 scale Meridian2 data (vector data from 1:50,000 LandRanger maps)

· 1:250,000 Strategi data (vector road and other data)

All these datasets are tiled into digital “map sheets” of a set size.  For example the 1:50,000 scale Landform Panorama data is provided in 20x20km tiles, while the 1:50,000 Meridian2 data is provided in 10x10km tiles.  Online manuals for each of these datasets can be found on the OS web pages at: http://www.ordnancesurvey.co.uk   

Digimap allows you to select up to 50 such tiles in any one download session.  These are transferred to your user space as Zip files containing NTF (National Transfer Format) data files, one for each tile requested.  These will need to be converted into GIS readable formats after the Digimap session is ended.

Running the Digimap Demo

Before starting the practical proper it is useful to view a short presentation of the Digimap website recorded as a Lotus ScreenCam.  The ScreenCam, which lasts approximately seven minutes, is available on the ISS's PC cluster desktop (Start>Programs>Miscellaneous>Digimap Demo).  

Task 1:  Run the Digimap Demo now.

Downloading OS digital map data using Digimap

You will have seen from the Digimap Demo that Digimap can be used to create maps onscreen and to download the raw OS digital map data for use in a GIS.  In this practical you will be downloading raster terrain model and vector line data for an area of your choice.  

Logging on to the Digimap website
The Digimap web site is accessed from http://www.edina.ac.uk/digimap.  This URL takes you the Digimap homepage as follows:
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Log on to the Digimap web service by clicking on the link to “Login”.  Clicking on the “Login” button produces a window for you to enter your username and password (see below).  Your username and password should have been sent to you in an email from the Digimap service team in Edinburgh. Click on the “OK” button after entering your username and password in the appropriate boxes.
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The next screen you should see is the EDINA Digimap copyright notice. Please read this and note the restrictions on use, then click on the green “I agree to the conditions” button at the bottom of the screen.
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Task 2: Log on to the Digimap web service now.

Downloading data from Digimap

The main Digimap interface should appear after you have logged on to the service.  Click on the “Data Download Services” tool (bottom right) to access the download facilities.
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This screen gives you access to “Digimap Download” and other services (see the Digimap demo for further information).  Click on the “Digimap Download” link.
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There are four methods of specifying the data to be downloaded from Digimap:

1. By National Grid co-ordinates;

2. By Ordnance Survey Tile name;

3. Using a Gazetteer; and

4. Using a map of Britain.

These are accessed from the Digimap Download screen as shown below…
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Identify by National Grid co-ordinates

If you know the National Grid co-ordinates of the area you wish to download data for, then the easiest way to select the tiles for download is by entering these co-ordinates for the lower left and upper right corners of the area of interest.  This is shown below…
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Entering the co-ordinates in the boxes, highlighting the products you wish to search for and clicking on the “View Tile List” button will display all the tiles that fall within the box specified.  The co-ordinates should be specified in full OS National Grid reference.  Be careful not to specify too large a search box, otherwise you will be overwhelmed with data!

Note:  There is a little flow chart on the right of the screen that gives you an indication of where you are in the download process with your current location highlighted in red.

Identify by Ordnance Survey tile name

Another easy way to search for data is by tile name.  If, for example, you know that the area of interest is in 100km tile “NZ” then you can enter “NZ” followed by “*” (the wildcard symbol) in the box provided, choose the product to search for and click on “View Tile Name List” as shown…
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Perform a Gazetteer search

If you do not know the National Grid co-ordinates or the OS tile name of the area of interest then you can use the Gazetteer (a list of placenames and their grid references) to search for data.  Digimap can locate placenames in the Gazetteer (or combinations of placenames for you to choose from) and then retrieve data for that area based on a specified search radius of 1, 5, 10, 25, 50kms and the specified products. For example, if you wanted to find all data products for the area within 1km of Northallerton, but didn’t know its co-ordinates or tile name, simply use the Gazetteer as follows…
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This will produce the following screen, from which you are requested to specify which of the placenames retrieved from the Gazetteer you want to download the data for…
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Identify using a map of Britain

The final method of search for data tiles, is interactive selection on the screen using a map of the country as follows…
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Selecting tiles to download

Whichever method you use to search for available data for the area of interest, you will then be asked to specify which tiles you want to download from a list of tiles matching the details of your search request.  Highlight the tiles you want to download from the lists given and then click on “Continue”.
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This generates a “summary report” of the data chosen as follows…
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Click on “Choose Data Format” to continue after checking the tiles are the correct ones.  This takes you to the “Choose Data Format” screen that allows you to specify the compression options.  The “zip archive” option is recommended for PC systems such as ISS.  Then specify the purpose the data is being used for (i.e. “learning”) and click on the “Extract data” button.

[image: image14.emf]


Once the data is extracted from the Digimap database you will be shown three links to files that are then available to download.  These are a “conditions of use” file (conditions.txt) listing the Digimap conditions you have agreed to, a “contents” file (contents.txt) listing the contents of the main zip file, and the “main data” file containing the data you have selected.  This last file always has a strange looking file name that has been randomly generated by Digimap (see below).  To download these files, simply click on the links and save them in your workspace.  The actual download process can take a few minutes, so please be patient.
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Task 3:  Use one of the four available methods to search for Landform Panorama DEM data and Meridian data for an area of your choosing and download these onto your workspace.  You need only download one tile of Landform Panorama data and one tile of Meridian data for this practical and the associated assessment.  Remember to save these in an appropriately named directory.

Converting Digimap NTF files for use in ArcGIS

The data you have just downloaded from Digimap is in NTF format (National Transfer Format) and is compressed in a standard Zip file.  This will need to be uncompressed and converted into ArcGIS readable formats using ESRI’s MapManager software.  MapManager is available on the ISS desktop (Programs>Mapping>MapManager).  This interface to MapManager is as follows…
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Files to be converted from NTF to ArcGIS readable format are selected using the main menu (File>Open) or the open folder icon on the far left.  This opens the “Select Ntf File For Conversion” window using which you need to navigate to and select the appropriate NTF files as follows…
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Once in the correct directory, the NTF files can either be selected using the mouse and Shift/Control keys as per other windows programs or all files can be selected using the “Select All Files” button.  Then click on “OK”.
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Three new windows are generated after the NTF files have been opened.  These are the “Selected Files”, “Output Format” and “Data Schema” windows.  These are used to display information on the selected NTF files, specify where the converted files are to be output and in what format, respectively.  These windows are shown below…
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Note: Ignore the blue highlighting of selected files as all selected files will be converted.

You may need to change the path of the output directory.  This is done by clicking on the “Change Dirtectory” button and navigating to the correct directory in the usual way.  You can also use this window to specify the output format.  For vector data it is best to choose “ArcInfo Rev 7/ArcGIS coverages” or “Shape File Format” (the latter is useful if you want to use the data with ArcView).  For raster data (e.g. the Landform Panorama DEM) then there are no options and the output will be as an ASCII file with the .asc extension.
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The Data Schema window allows you to make choices about which data layers to convert, but for now just leave this window as it is.
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When you are ready to convert the selected NTF files, simply click on the red arrow icon on the menu bar.  The files will be converted and the ArcGIS readable files/coverages placed in the specified output directory.

Note 1:  The vector data (Meridian2) will be converted directory to an ArcGIS coverage or shape file (depending on your choice).  The raster data (Landform Panorama) will be converted to an ASCII file.  You therefore need to convert the ASCII file to an Arc GRID coverage using the ASCIIGRID command in the Arc 8.2 “black box” as per Practical 1.

Note 2: If you have chosen to convert the vector data to an ArcGIS coverage this actually creates a new directory in the specified workspace that contains three separate ArcGIS coverages: ospoints, oslines and osanno.  These contain the point data, the line data and the annotation data respectively.  It then makes subsequent work easier if you copy these ArcGIS coverages to your work main workspace for this practical using the COPY command in Arc as follows:

Arc: COPY meridian-se39/oslines oslines-se39

Where:

meridian-se39 is the new directory created by MapManager,

oslines is the ArcGIS line coverage containing the vector line data, and

oslines-se39 is the new ArcGIS line coverage created in your workspace

Task 4: Unzip the Digimap download file and use MapManager to convert your NTF data files now.  Convert the ASCII file using ASCIIGRID in Arc.

Creating maps in ArcMap

One of the principal uses of ArcMap is to make maps of cartographic quality that can be used in reports (or your dissertation).  Practical 1 showed how digital map data can be draw on the screen using ArcMap for visualisation and interrogation purposes.  The screen shot below shows Meridian2 vector data drawn over Landform Panorama data for the Northallerton area…
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“Windowing” raster DEM data

Because the Meridian tiles cover an area 10x10km whereas the Landform Panorama DEM tiles cover an area 20x20km, the Meridian data you have downloaded will not cover all the Landform Panorama data.  To reduce the area of the Landform Panorama data to same area covered by the Meridian it is possible to select a “window” of the data and save this as a new file which can then be used to create a map in ArcMap.  This is done atthe ArcGRID command line as follows:

GRID: &workspace m:\prac2
….specifies the workspace

GRID: mape se28


…specifies the mapextent for the data

GRID: image se28


…draws the DEM data

GRID: setwindow meridian-se39
…sets window based on Meridian data

GRID: se39 = se28


…makes windowed copy of DEM

Task 5:  Create a “windowed” copy of the Landform Panorama DEM data based on the Meridian 10x10km window using ArcGRID.

Cartographic annotation can be added to your map display by switching to “Layout view” (small page icon to right of globe at lower left of main display window). The insert item on the top menu then gives you access to a menu of tools for adding cartographic annotation to your map.  As a basic rule a map should contain a title, an indication of scale and orientation and a legend describing the symbolism used in the map itself.  All these can be added using the insert menus.  A title is added by clicking on Insert > Title and editing the “Enter map title” box that appears on the map.  All these items are floating and can be selected by clicking on them and moved/re-sized using the mouse and associated menus/control bars.
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A legend can be added using Insert > Legend. Legend items to be displayed can be changed by moving items from the left hand window to the right hand window in the Legend wizard.  Legend items not in the right hand window will not be displayed on the map. A preview can be obtained by clicking on “preview” before clicking on “next”.  The preview is switched off by clicking on “preview” for a second time.
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The legend title is edited and controlled in the next window.
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Borders, background colour, shadows, etc are controlled in the next window.
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Size and shape of the symbol patches and line/polygon features, but the defaults are perfectly acceptable so click on “Next”.
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The last window controls the spacing between legend items.  Again, the defaults are perfectly acceptable so click on “Finish”. Once done, you can select, move and resize your legend to suit.  You may have to resize the map in order to make space for the legend on the page.  The title used for each layer in your legend will be the same as that shown in the layers window down the left hand side of the display.  Most grid layers will be labelled simply as “Value”.  You can alter this by highlighting the label in the layer window and editing this to something more sensible (e.g. “Altitude in metres” for your DEM layer).
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Adding a scale bar is also a cinch, but you must first remember to set the map and display units using the Data Frame Properties menu.  This is accessed via View > Data Frame Properties.  Click on the “General” tab and change the map and display units from “Unknown units” to the appropriate measurement (usually meters for OS data). 
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Next use Insert > Scale bar to bring up the Scale Bar Selector window from which you can choose a style of scale bar that you like.  
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Clicking on the “Properties” button brings up a further window that allows you to control such things as the number of subdivisions on the scale bar, the units and format. Click on “OK” and then “OK” in the original scale bar window to add the scale bar to your map.
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Again, you can click on your scale bar once its on your map to select it, move and resize it.  Again, right clicking on a selected item allows you to further edit its properties if you want to make more changes.  Finally, you should add a north arrow.  This is done using Insert > North Arrow and selecting the style you want from the resulting window. North is normally at the top of the map, but you can control the orientation of the arrow in the “Properties” window. 

If necessary you can add further text to you map using Insert > Text.  This can be used to add copyright statements, descriptions about data sources, etc.

As a general rule “KISS”  …Keep It Sensibly Simple.  ArcMap allows you great control over the finished product but use it sensibly and avoid “Chart Junk” and over gaudy colours. Remember, your map is a communication device and as such should contain everything needed to read and understand it, and nothing more. Above all, there should be nothing on your map about hidden treasure and “here be dragons” found on old pirate maps!  The example below is sufficient for this practical.
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To print out your map, use File > Print and select the appropriate printer from the print window.  ArcMap is a WYSIWYG display interace (“what You See Is What You Get”) but it might nonetheless be wise to examine the printer output using File > Print Preview first.
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Task 6. Display in your map ArcMap and add cartographic annotation before printing out. This will form part of your next Assignment (see Assignment 6 Answer Sheet).

