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	Practical 8 and Assignment 5:

 Correcting a LiDAR DSM to obtain an estimated DEM

Week 10




Task:

To use ERDAS Imagine to remove typical surface extrusions from a LiDAR DSM (Digital Surface Model) in order to obtain a better estimate of the true surface topography of an area. The result of this process will be an estimated DEM (Digital Elevation Model).

Deadline: Wednesday the 8th of December. Hand in your assignment to reception by 2pm. Remember to get a receipt.
Assignment Guidance:

(i) You should complete this assignment as an individual piece of work. Therefore, working in groups is not permitted. It is recommended that you start the assignment before the 2-hour practical session on Wednesday 1st of December. A demonstrator will be available to give assistance. However, as this assignment is assessed demonstrator assistance will be limited to addressing basic technical issues on the use of ERDAS Imagine and explaining the general concepts involved in the processing you have to perform for the assignment.

(ii) An answer sheet for the assignment is provided on the last few pages of this handout. You can also download a separate version of this (called: Practical 8 Assignment 5 answer sheet) from the Nathan Bodington Geog2750 practical material room in order to format your assignment for printing and submission.
(iii) To complete the assignment you will need to include a few diagrams of spatial models that you have developed in ERDAS Imagine and a copy of the final image. Unfortunately, the ISS PCs are not configured for printing from ERDAS Imagine. Thus, in order to produce these it is suggested that you use the Print Screen keyboard facility and paste your results into the assignment answer sheets. If you then select the pasted screen capture in your WORD document you can use the Picture toolbar that appears to crop and re-size your pictures of the spatial models and images. The Picture toolbar should automatically appear when you select a pasted graphic, or can be set to appear by selecting View->Toolbars->Picture. The Picture toolbar is shown below with the Crop tool highlighted.
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- Experiment displaying the histogram of cach spectral band of the practical session image.

- The next means by which pixel valucs can be obtain is to use Imagines Profife tool which can be
E aceessed by selocting the Profile icon from the image viewer — this icon is shown below.
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1. The Practical Session Data Sets and Preparation

The data sets employed in this practical/assignment are provided via the Nathan Bodington Geog2750 practical material room. These are stored as Zip (compressed) files that need to be copied onto your ISS drive. To do this:

1. The data sets for this practical can be accessed from the Nathan Bodington Geog2750 practical materials page.
2. Right click on the data-set link of practical 8 and use the “Save Target/Link as” option to save the zip file to the practical folder you created in practical 1.
3. Use WinZip or PowerZip to unzip (uncompress) the contents of the Zip file. The Zip file is called buckden.zip. It contains three files: buckden_sm_dsm.img, buckden_sm_class.img and buckden_sm_rgb.img. A description of these files is given below.
4. IMPORTANT – it is just possible that some computers will not have WinZip or PowerZip installed. If this is the case you should be able to extract the practical data set by the following. In Internet Explorer, left mouse (on some computers it may be right mouse!) select the practical data set link and select the File Down Load option. Select Open from the dialog box that appears. Select the data set in the new window that appears and then the File->Extract All option from the menu of the window. This should start a download Microsoft Wizard for you, which will take you through the further stages of the extraction process. Use the wizard to extract the data-set to folder on your M drive that you have created for this practical.
Once you have successfully extracted the three practical session data sets you should start ERDAS Imagine and display the data. All three images cover the same small area of the Wharf Valley close to the town of Buckden.

buckden_sm_dsm.img – is an Environment Agency LiDAR DSM that has been collected with a spatial point density of 2m. However, for the purposes of this practical its spatial resolution has been resampled (enlarged) to a spatial resolution of ~66cm per-pixel (check the skip factor of this image in the image layer info for creation of the corrected DSM). The pixel values in the DSM refer to the surface height of each location (in meters e.g., 232.68m). This LiDAR DSM contains a number of notable surface extrusions that means that in certain locations it does not correspond to a true representation of the topographic surface of the area. The most important of these are areas of trees and also a large building. It is these surface extrusions that you will try to remove in this practical/assignment in order to get a better estimate of the surface topography (i.e., to obtain an estimated DEM – Digital Elevation Model).
buckden_sm_rgb.img – is a three band colour aerial photograph of exactly the same area covered by the LiDAR DSM. This data has been collected with a spatial resolution of ~66cm (hence why the LiDAR data has been resampled to a spatial resolution of 66cm). This data has been used to produce a classification of the land cover types present in the study area. It has been provided for this practical/assignment in order to allow you to recognize the important features – particularly areas of trees and buildings. You will also find it a useful visual aid in evaluating the quality of your results.

buckden_sm_class.img – is a classification of main land cover types present in the study area. This classification has been produced using the aerial photography. It is this classification that you will use to try and remove the height contribution to the LiDAR DSM for extruding areas of trees and buildings.  The classification contains the following classes and assigned pixel values:

Class



Pixel Value

Unclassified


0
Hill Tops2 (moorland)
1

Buildings


3

Walls



6

Trees



7

Hill Tops (soil)

8

Dark Fields


9

Light Fields


10
Before proceeding any further with the practical/assignment you should display each of these images and become familiar with them visually.
2. Practical/Assignment Description
The task that you need to complete for this practical/assessment is to use the classified aerial photography to try and remove from the LiDAR DSM the height contributed by areas of trees and buildings. In order to do this you will implement a relatively simple approach, which will have the following stages:

1 Extracting from the land cover classification separate Boolean masks that represent classified areas of Trees and Buildings.

2 Define for the Trees and Buildings a typical value in meters that you feel that they extrude above the true surface topography of the study area.

3 Derive using the Boolean masks and extrusion values set in stage 2 two data sets that represent for each Tree or Building pixel its extrusion height.

4 Subtract from the original LiDAR DSM the extrusion height data sets for the Trees and Buildings to obtain an estimated Digital Elevation Model corrected for Trees and Buildings.

3. Extracting Boolean Masks of Trees & Buildings
In order to extract the Boolean masks for Trees and Buildings you will need to have the classified image displayed (buckden_sm_class.img). In the viewer displaying this image, select Raster->Tools. This will open the Raster tool palette. In this you want to select the Recode Area icon, as annotated on the Raster tool palette shown below:
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This will result in a new window being opened for you shown below (you may need to expand this to see all the columns):
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You will need to use this interactive edit box to generate the Boolean mask for Tree and Buildings. To generate the Boolean mask for Trees you need to set the new value column entry for the Trees class to be 1, while the new value for all other classes needs to be set to 0. To do this, first set the New Value entry dialog (shown above) to have a value of 0. Then individually for each class other than the Trees class, left mouse select the class Row and then select the Change Selected Rows option. You need to repeat this for each class (i.e., rows 1 to 10 apart from row 7 which corresponds to Trees). You should find that now in the column New Value each class has been assigned a value of 0. Next set the New Value of the Trees class (row 7) to have a value of 1. Finally, select Apply. This should change the classified image in the viewer to a Boolean data set similar to that shown below:
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In this image, all pixels that are Trees have a value of 1, while all other classes have a value of 0. You now need to save this image. To do this select the File->Save->Save As option and save the Boolean mask to file called trees_boolean.img. You now need to repeat the Boolean mask generation again. However, this time you want to set the Building class to have a New Value of 1 and all other classes to have a value of 0. You will also need to save this file in the same manner as above. You should call this file built_boolean.img.
5. Building a Spatial Model to Remove Tree and Building Extrusions

In order to remove the height of Trees and Buildings from the LiDAR DSM in order to get an estimated DEM you will need to use the (spatial) Modeller in ERDAS Imagine as you did earlier in this module.  Your model needs to take each Boolean mask and multiply it by the extrusion heights that you think Trees and Buildings will typically extrude above the topographic surface. This will then create a series of temporary data set that will contain the extrusion heights for Tree and Building pixels respectively. This is because in each mask you generated, pixels that are not Trees for the trees mask or buildings for the building mask have values of 0. Thus, multiplying these pixels by the corresponding extrusion height of Trees and Buildings respectively will always give 0. However, the pixels that are Trees and Buildings have a pixel value of 1, which when multiplied by their corresponding extrusion height will give temporary data sets where all Tree or Building pixels have a value now that corresponds to the extrusion heights set. The final stage of your model, will involve subtracting the temporary data sets from the LiDAR DSM to obtain an estimated DEM.

Below the model that you need to produce has been partially completed for you. In this case it is for the Trees. You will need to duplicate this and then extend it to include a subtraction of the Building extrusion heights.
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Once you have completed the full model – one that subtracts the extrusion heights of Tree and Building pixels from the LiDAR DSM – you will need to run the model to generate the final corrected estimated DEM.

It is unlikely that your first selected set of extrusion heights will be the best for removing extruding Trees and Buildings. Thus, an important component of this practical/assignment involves experimenting with setting different extrusion heights for both Trees and Buildings at stage (2) shown above until you feel you have produced an acceptable estimated DEM (i.e., you have removed as much of the extrusion height as possible while producing a realistic underlying surface topography). 
5. Interpretation and Validation of the Correction

It is up to you to decide the methods you adopt to interpret and validate the quality of the correction you have applied in order to provide answers to the assignment questions set below. In previous practicals/assessments you have had to use the general analysis tools of ERDAS Imagine to interactively derive and analyze the properties of images. You are also now familiar with interpreting the information contained in the File->Layer Info window. Moreover, you have used extensively the ERDAS spatial modeler. Some or all of these tools/components of ERDAS Imagine could be employed to interpret and validate the quality of the correction you have applied. Also remember that as a visual aid you have available the aerial photography. Finally, it may help you visually in your interpretation and validation if you apply certain contrast stretches to the original and corrected LiDAR DSMs. To do this you should experiment with the different contrast stretch options available in the contrast enhancement tool which from the image viewer can be started by selecting Raster->Contrast->General Contrast.
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University of Leeds

Assignment 5
Correcting a LiDAR DSM to obtain an estimated DEM 

Marked out of a total of 25 marks
Deadline: 2pm Wednesday the 8th of December 2004.

Name:

Programme:

Deliverable 1 (5 marks): Provide a suitably cropped screen-capture of your ERDAS Imagine Spatial Model for correcting the Tree and Building height extrusions in the LiDAR DSM.

Paste your spatial model on this page.
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University of Leeds

Deliverable 2 (2 marks): Provide a suitably cropped screen-capture of your corrected LiDAR DSM. 

Paste your corrected LiDAR DSM here.
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University of Leeds

Question 1 (3 marks): Using ERDAS Imagine derive the overall minimum, mean and maximum of the original LiDAR DSM and your corrected version; and the values used  for your trees and buildings extrusion height variable in your final spatial model. (Check that the skip factor of your corrected DSM is the same as the original DSM to derive image statistics, see layer info).
Original LiDAR DSM
	Overall Minimum height
	Overall Mean height
	Overall Maximum height

	
	
	


Corrected LiDAR DSM

	Overall Minimum height
	Overall Mean height
	Overall Maximum height

	
	
	


Extrusion height variables

	Trees
	Buildings
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University of Leeds

Question 2 (10 marks, 300 word maximum): On the basis of the analysis you have conducted between your corrected and the original LiDAR DSM interpret and discuss how well you feel the correction procedure has removed height extrusions resulting from Trees and Buildings. In your discussion you should state the final extrusion height you selected for the Trees and Buildings. You should also present evidence to support the interpretation and discussion. This might be in the form of general statistics, quantitative evidence of validation and/or graphical material.
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University of Leeds

Question 3 (5 marks, 150 word maximum): Other than the validation you have performed and the data sets available to you, what other forms of validation and/or data sets do you think would be appropriate in order to evaluate the quality of the correction you have performed.

Select Recode Area Icon





Crop tool for cropping unwanted areas from Pictures.





















































(1) Input trees_boolean.img

































































































































































Answer to Question 3:








Answer to Question 2:








(2) Multiply by your selected trees extrusion height. In this example it has been set to 2.5 (meters) - $n1_trees_boolean * 2.5





(3) Set as a temporary float raster





(4) Input buckden_sm_dsm.img





(5) subtract each temporary raster of extrusion heights for trees (and buildings) from the buckden_sm_dsm.img.





(6) Make sure your final corrected data set has a data type of float single








