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Task:

In this practical session we are going to cover how two different images data sets covering the same area of the Earth’s surface can be geometrically registered in order to allow their joint analysis. This practical will also introduce you to the ERS2 Synthetic Aperture Radar (SAR) image that will form the basis of practical 7 and assessment number 4. There is no assignment with this practical.
Practical Aims 
1. To introduce you to the procedure of how two different images of the same area of the earth’s surface can be geometrically registered.
2. To allow you to gain familiarity with the ERS2 Synthetic Aperture Radar image that will be used in practical 7 and assessment 4.
1. The Practical Session Data Set and Preparation

1.1
Copying the Practical Session Data Sets

As in the case of the previous practicals, the first practical data set for this session is the Landsat 5 Thematic Mapper (TM) image that covers north west England and part of north Wales. For most of you this will be called WIR12345.

The second practical data set consists of an ERS2 (European Resources Satellite) Synthetic Aperture Radar (SAR) image covering broadly the same area as the Landsat 5 Thematic Mapper image. This data set in the form of a ZIP file that can be downloaded from the Geog2750 Nathan Bodington practical material room using the data-set link of practical 6. The ZIP file is called wir_ers2.zip. You will need to unzip this file to obtain the ERS2 SAR image, using the procedure(s) outlined in practical session 1. Once you unzipped the ZIP file wir_ers2.zip you should have a file called:
WIR_ERS2.img

This is the ERS2 SAR image covering the approximate the same area as the Landsat 5 Thematic Mapper image. This image is already formatted as an Imagine image, has a spatial resolution of 30m (the same as the Landsat 5 Thematic Mapper image) and has 1024 rows and 1024 columns (again the same as the Landsat 5 Thematic Mapper image).

2. Displaying the ERS2 Synthetic Aperture Radar Image
Before proceeding with the geometric correction and registration exercise, it is worth ensuring that you can display the ERS2 SAR image WIR_ERS2.img. Start Imagine and in a Viewer load in the ERS2 SAR image for display. The resulting image should look similar to the one shown below when scaled to fit in the image window (View->Scale->Image To Window command).
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It was noted in lecture 7 that active microwave images such as those acquired by synthetic aperture radar sensors do not bear a resemblance to optical images, such as the Landsat 5 Thematic Mapper image of this area. We will cover in greater detail in lecture 8, practical 7 and assignment 4 why this is, and more importantly what controls the nature of the microwave backscatter recorded by sensors such as ERS2. Today, however, all you need to do is familiarize yourself with ‘what’ synthetic aperture radar images typically look like when displayed.
3. Preparing for the Geometric Correction and Registration

The main part of this practical session involves you trying to co-register as precisely as possible the Landsat 5 Thematic Mapper image and the ERS2 SAR image. While these both broadly cover the same area of the Earth’s surface, areas that are the same in the two images do not precisely match. This is because the Landsat 5 Thematic Mapper image has not been acquired or processed to the level that ensures it is correctly geographically orientated. However, the ERS2 SAR image WIR_ERS2.img has been corrected such that from the bottom to the top of the image, when displayed, corresponds to North and that all pixels represent their true location on the Earth’s surface.
You should at this stage display, in separate viewers, both the Landsat 5 Thematic Mapper image (WIR12345.img) and the ERS2 SAR image (WIR_ERS2.img). A close visual display will confirm that the two images do not have the same geometric orientation. If we wished to use both of these images in a quantitative analysis – for example, to map vegetation and soil patterns – they need to be co-registered to each other in order to remove any changes in orientation, scale and distortion between them. In this particular case, we are going to do this by registering the Landsat Thematic Mapper image to the ERS2 SAR image, as the ERS2 SAR image is, as mentioned above, already processed to the level that it is geographically correct.
4. Pre-Geometric Correction Considerations – A Brief Discussion

Before commencing with a description of how to use Imagine to geometrically correct an image data set this section will outline briefly several considerations of image geometric correction. To aid you with the following material you may wish to go through again the geometric correction material covered in Lecture 3.
4.1
Exercise Objective

The objective of this exercise is to geometrically correct the Landsat 5 Thematic Mapper image and register it to the ERS2 SAR image.  Thus, the result will be an image that geometrically is in the same coordinate system as the ERS2 SAR data.
4.2
What Order Polynomial
When image data sets are displayed the Y axis is taken to represent locations that are truly north facing.  However, the Landsat 5 Thematic Mapper image data set has been acquired on a nadir track that does not run north-to-south.  In fact its true nadir track (azimuthal angular ground tack direction) is approximately 8 degrees from North.  Thus, when the image is displayed, the columns do not represent truly north orientated locations.  Such a rotational geometric distortion is a first-order distortion, in that it can be expressed and corrected using a linear 3-parameter polynomial fit.

If the above geometric distortion is the only geometric distortion present in the image, then this could be corrected using only this form of polynomial.  However, many images are prone to localized higher-order distortions such as X and Y axis bending or warping. These affects often manifest themselves as localized higher-order distortions in the image – that is visibly localized geometric distortions of bending or warping – and as such cannot be corrected using a linear 3 parameter polynomial.  In order to correct these geometric distortions a 2nd order or higher polynomial must be used.

The above discussion highlights that in many cases the geometric correction of remotely-sensed images is a trade off been representing well the global rotational distortion (first-order) and localized 2nd order or higher bending and warping.  Often, it is possible to use a 3rd order polynomial or higher to model/represent very accurately localized distortions but this will often have a detrimental affect on how well we can correct the overall linear distortion.  Likewise, the use of a linear 3 parameter polynomial means that it is not possible to correct at all any higher-order geometric distortions.  Often a good compromise between these two extremes can be achieved by using a 2nd order (quadratic) polynomial.

However, in the case of Landsat 5 Thematic Mapper image nearly all of the distortion is a result of angular nadir track of the sensor being 8 degrees from true north. As such, you should use a 1st order polynomial to correct its distortion and register it to the ERS2 SAR image. However, feel free to experiment with different order polynomials so that you can familiarize yourself with the issues discussed above.

3.2 How Many Control Points

The second important consideration is how many ground control points you need to collect to perform a robust accurate correction of the image.  The number of coefficients that are required by the order of polynomial that you are going to fit dictates the absolute minimum.  In short, at least an equal number plus one ground control points are required for the number of coefficients in the polynomial expression.  Thus, in order to use a 1st order polynomial you will require a minimum of 4 ground control points, to use a 2nd order you will need a minimum of 7 ground control points and to use a 3rd order polynomial you will need at least 11 ground control points.

In order to achieve a good correction, however, you will need to collect more than these minimum values.  Many texts recommend between 20-30 ground control points, although many corrections are routinely performed on the basis of between 10-20.  You should aim to collect approximately 10 ground control points covering the entire spatial extent of the images.  In addition to these, you will need to collect a set of verification points.  Verification points are points that you select at the same time as the ground control points but do not use in the calculation of the coefficients for the polynomial correction.  You can use these points after the correction coefficients have been calculated to derive a quantitative indication of how well the correction will work for locations not explicitly included in the polynomial calculation.  You should aim to derive 5 verification points.  How they can be used for checking the quality of the correction will be outlined latter.

3.3 What Resampling Approach to Use

As outlined in Lecture 3, nearest neighbour resampling ensures that the minimum of changes occur for the original histograms of each spectral-band being corrected.  However, this form of resampling produces the least visually pleasing corrected image.  If the resulting images are not to be used for quantitative remote sensing analysis, then a visually better image can be achieved using bilinear and bicubic resampling approaches.  For this exercise, you should use nearest neighbour resampling.  If time permits, however, you may wish to use bilinear and bicubic and compare the histograms of the three corrected images to that of the original input image.  This comparison does not involve the collection of any more ground control points.

3.4 What Spectral-Band Combinations to Use for Point Collection

By default, when you display the Landsat 5 Thematic Mapper image data set to be corrected Imagine will assign particular spectral-bands to particular colour-guns of the display.  You should experiment with which spectral-band combination visually allows you to discern the boundaries between the objects present in the scene.  In the case of the Landsat 5 Thematic Mapper image, you are likely to use field corners, road corners/intersections etc to define your ground control points.  In order to select different spectral-band combinations you can use the Raster->Band Combination entry dialog in the image viewer entry dialog to change the band combinations and associated colour-gun assignment.  As a tip, do not dismiss using just a single spectral-band for the collection of ground control points as often an individual band can allow visually a better discrimination of certain objects than a false or true colour composite.  If you wish to use a single spectral band, then you should set each colour-gun to correspond to its band number. The result will be a grey-scale image in the Viewer.
4.
Using Imagine to Geometrically Correct the Multispectral Airborne Image

2.1 Setting up the Geometric Correction Tool

Imagine’s geometric correction tool can be started by selecting the Data Prep->Image Geometric Correction option.  This will result in a new entry dialog appearing on the screen.  When this appears select the From Image File option and use the file manager to select the Landsat 5 Thematic Mapper image WIR12345.img.  Once this has been selected the image will be displayed in a Viewer and a further entry dialog box will appear.  In this new entry dialog window select Polynomial and press “OK”.  Two new entry dialog windows will now appear as shown below:
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In the entry dialog window directly above set the Polynomial Order to 1 and select the “Close” option.  This will result in a further new entry dialog window appearing.  This window requires you to specify how you wish to relate ground control points recognized in the image to the same corresponding points of known geographic location.  In the case of this practical session, we will use the ERS2 SAR image (WIR_ERS.img) to select points corresponding to true geographic locations. However, you should be aware that the true geographic location of the ground control points could be selected or defined in a number of ways.  One of the most common is to enter via the keyboard at the time a particular ground control point is selected in the image its corresponding geographic location from a map.

In order to display the ERS2 SAR image (WIR_ERS.img) that we are going to use to define the true location of selected ground control points, select Image Layer (New Viewer).  This will result in a file manager appearing which you should use to select the ERS2 SAR image (WIR_ERS.img).  Once this has been selected, select “OK” in the dialog window that appears – this should result in the image appearing, along with several new entry dialog windows.  The layout of windows at the end of this stage should like similar to the figure below:
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4.2
Selecting Ground Control Points

Before proceeding with collection of ground control points you should ensure that you de-select the check-boxes shown above.  In the above figure, the image to be corrected (on the left) has a small cross-hair graphical box, the area of which is shown in the corresponding zoomed image immediately above.  Similarly, the reference ERS2 SAR image (right) also has a small cross-hair graphical box, the area of which is shown in the corresponding zoomed image immediately above it.  In the case of each image, as you scroll in the main image Viewer the location of the cross-hair box and its corresponding zoomed area display is updated.

The specification of a control point is relatively straightforward.  First use the scroll utility to move to the part of the image that is to be corrected (left main Viewer) that contains the area you wish to specify a ground control point for. Select the Select GCP icon shown below:
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Once this is active, you can select the cross-hair box in the image to be corrected (left main image Viewer) and drag it to the approximate pixel you wish to select as a ground-control point.  Once you have the cross-hair box over the area containing the pixel you wish to specify as a ground control point you need to select the Create GCP icon, shown below:

[image: image12.png]Help





Now, very carefully, in the zoomed image above the main Viewer of the image you are correcting select the precise pixel location of the ground control point.  This should result in the main GCP dialog box (bottom in the above figure) being updated with the X and Y location of the selected pixel and text appearing on the main image Viewer stating the ground control number.

At this point you have selected a ground control point in the image that is to be corrected.  However, you still need to specify its true geographic location in the corresponding rasterised ERS2 SAR image.  To do this move the cross-hair box in the ERS SAR Viewer (main right Viewer) to the approximate true geographic location of ground control point just selected.  Again select the Create GCP icon and in the zoomed box select, again carefully, the pixel that corresponds to the true geographic location of the ground control point selected in the image being corrected.  This should result in the main GCP dialog box being updated again for the same control point.  In particular, you should have for your single ground control point its input X and Y and also now its X ref and Y ref coordinates.

Once you have performed this operation you can move onto the selection of your next ground control point.  It is worth noting that if you wish to edit a ground control point in either image this can be achieved by simply selecting the text referring to a particular ground control in either of the main Viewers or in their corresponding zoomed sub-images when the Select GCP icon, shown below, is set (not the Create GCP icon):
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This option is particularly useful if you need to adjust the location of a ground control point that results in a large error when the polynomial transformation is calculated.  In a similar vain, a ground control point can be completely deleted by selecting with the left mouse button the GCP number in the main GCP dialog and then with the right mouse button selecting the Delete Selection option.

At this stage, you should proceed with selecting the ground control points for the geometric correction.  Remember that if you have selected a 1st order polynomial then you will need at least 4 ground control points.  However, attempt to recognize 10, spaced throughout the entire spatial extent of the image to be corrected. Note: you may find after your first couple of GCPs that Imagine places pre-emptive GCPs in your reference image (wir_ers.img), if these are not close to your reference location, move them with your cursor to the correct reference location.
Once you have selected your 10 or so ground control points you should also collect at least 5 check verification points.  In order to do this, you perform exactly the same procedure as above, but of course for different locations.  In general, you should try to select check verification points which are spatially distinct from your ground control, as they will be used to quantify how well the polynomial is estimating the correction for locations not used to explicitly define the coefficients.  In order to set check verification point selection mode, simply select the next empty GCP entry in the main GCP window and then select Edit->Set Point Type->Check.  Each new set of points entered will now be check verification locations and will not be used in the estimation of the polynomial coefficients.  Once you have selected your 5 or so check verification points you are ready to see how well your GCP’s are performing in defining the polynomial transformation from the Landsat 5 Thematic Mapper image to the ERS2 SAR data.

4.3
Deriving the Polynomial Coefficients

Once you have selected your ground control points and check verification points the next stage involves actually calculating the coefficients of the polynomial you are going to use to correct the Landsat 5 Thematic Mapper image to the ERS2 SAR image.  This is achieved by selecting the Solve Geometric Model with Control Points icon, shown below (note: if you do not have enough GCP’s for the order of polynomial selected this icon will not be selectable):

[image: image14.png]I3 [ 5

Paranetrs | Tansfomatin| Fioecion|

PobrorialOrder. |1 4 Reset

0

Save
Saveds
Load CFF File
Close.

Help

el el el

Status: _ Model has n saluton





This will result in the Imagine calculating the coefficients for the order of polynomial selected and filling in the remaining entries for each control point in the main GCP window.  The result of this procedure will be a GCP table similar to the one shown below:
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In the updated table, the important entries are the X residual, Y residual and the RMS error of individual points.  The X and Y residuals tell you the difference between the actual location of a ground control point in the ERS2 SAR image and that estimated as a result of the calculation of the coefficients of the polynomial – rarely are the true locations and estimated the same as we are using essentially a form of regression.  The RMS error tells you the combined error taking into account both the X and Y residuals (error) for each individual point.  Clearly, points which have a high RMS error should be edited as described above for the X, Y or both X and Y residuals that seem to be contributing the greatest to the individual RMS error.  Once editing has been completed the coefficients can be re-calculated to evaluate the new X, Y residuals and RMS error.  The aim of this stage of geometric correction is to try to minimize the individual RMS errors of the ground control points.  However, you should note, that changing a single ground control point will have an influence on the RMS errors of the other ground control points used.  Occasionally, the influence can be negative rather than positive, that is, improving the individual RMS error of one particular point may actually worsen the RMS of other points!
4.5 Using the Check Verification Points

The above stage has generated the polynomial coefficients for the order of fit you have specified.  However, it has not actually geometrically corrected the Landsat 5 Thematic Mapper image to the ERS2 SAR image.  Before doing this, however, you should check how well the polynomial coefficients are performing for the ground control you have selected by using the check verification points.  This can be achieved by selecting the Compute Error for Check Points icon shown below:
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This will result in the X and Y residual boxes and RMS error box being filled in for each of the check boxes.  In general one would expect the X and Y residuals and RMS error for check verification points to be worse (higher) than for the ground control points as they have not been directly used in the calculation of the polynomial coefficients.  However, if these values are significantly larger than the ground control error then you should not only consider editing the exiting ground control points but also adding further ground control to the locations where the check verification points are giving high X and Y residuals and RMS error.

In absolute terms, a good quality correction of this image data set would be one  - assuming a good spatial sample of ground control – where the average ground control and check verification RMS error is below 60 meters, although an error of between 60-120 meters is a likely level to achieve during the course of this practical session.

4.6 Generating a Geometrically Corrected Image

Once you have got your ground control and check verification points to a RMS error of less than 120 meters (or if you are running out of time!) you should actually geometrically correct the image.  This can be achieved by selecting, in the Geo Correction Tools dialog window (shown below) the Display Image Resample Dialog (again shown below).
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This will result in a further dialog entry window appearing on the screen.  In this new dialog entry box you should use the file manager option to set the name of the geometrically corrected image file to be created, and set the Output Corners and Output Cell Sizes to be the values set in the example shown below.  Finally, select “OK”.
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The result of this process will be a geometrically corrected version of the original Landsat 5 Thematic Mapper image.  You should display the corrected image in a new image Viewer and ensure that the results look visually sensible. Using the cursor inquiry mode select a small number of independent pixels in the corrected image and check that they have broadly the same row and column location as the same point in the ERS2 SAR image which has been used to perform the geometric correction.  

5. Wrapping Up

Before quitting the geometric correction tool you should save the ground points and coefficients you have calculated.  This will allow you to use them at a latter date if you wish to attempt to refine your geometric correction.  You can save the information relating to the ground control points selected for the Landsat 5 Thematic Mapper image by selecting in the main GCP window the File->Save Input As option and specifying a folder in which to create a new file containing the ground control information.  In a similar manner, you can save the information relating to the corresponding ground control points of the ERS2 SAR image by selecting in the main GCP window the File->Save Reference As option and again specifying a folder in which to create a new file containing the related ground control information.  Both these sets of related ground control can then be reloaded at a latter stage when you start the geometric correction tool again.

Additionally you SHOULD NOT delete the geometrically corrected image (regardless of how well it has been corrected).  This image may prove useful in next week’s practical session to investigate the ERS2 SAR image for assignment 4.

NOTE: access the practical session 7 handout at the beginning of Week 9 from the Nathan Bodington Geog2750 practical material room prior to the Week 9 timetabled practical class.  You can download the practical handout to your ISS folder, keep your downloaded practical handout document open or print off a copy for the practical session.
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