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Producing a Land Cover Classification of a Landsat 5 Thematic Mapper Image

Week 6




Task:

To use ERDAS Imagine to classify the Landsat 5 Thematic Mapper image of north west England and north Wales in order to obtain a land cover thematic map of the area. To perform accuracy assessment of your land cover classification to evaluate its quality.

Deadline:  Friday the 12th of November (Note 2 days extra for this assignment).  Hand in your assignment to reception by 2pm. Remember to get a receipt.
Assignment Guidance:

(i) You should complete this assignment as an individual piece of work. Therefore, working in groups is not permitted. It is recommended that you start the assignment in the 2-hour practical session on Wednesday 3rd of November. A demonstrator will be available to give assistance. However, as this assignment is assessed demonstrator assistance will be limited to addressing basic technical issues on the use of ERDAS Imagine and explaining the general concepts involved in the processing you have to perform for the assignment.

(ii) An answer sheet for the assignment is provided on the last few pages of this handout. You can also download a separate version of this (called: Practical 5 Assignment 3 answer sheet) from the Nathan Bodington Geog2750 practical material room in order to format your assignment for printing and submission.

(iii) To complete the assignment you will need to include a few diagrams of spatial models that you have developed in ERDAS Imagine and a copy of the final image. Unfortunately, the ISS PCs are not configured for printing from ERDAS Imagine. Thus, in order to produce these it is suggested that you use the Print Screen keyboard facility and paste your results into the assignment answer sheets. If you then select the pasted screen capture in your WORD document you can use the Picture toolbar that appears to crop and re-size your pictures of the spatial models and images. The Picture toolbar should automatically appear when you select a pasted graphic, or can be set to appear by selecting View->Toolbars->Picture. The Picture toolbar is shown below with the Crop tool highlighted.
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1. The Assignment Data Set and Preparation

In this practical assignment you will use the original Landsat 5 Thematic Mapper image that you read into ERDAS Imagine in the first practical session in week 2. If you have been following the file naming conventions suggested, this data set will be named wir12345.img.

To complete this assignment fully you will have to use a number of new components of ERDAS Imagine. I would suggest that you consider working through the entire practical in the practical session on Wednesday 3rd of November, and then attempt to complete the assignment in full after this. With this in mind, you have been given two extra days during reading week to complete this assignment compared to the others.
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2. Recognizing the Principal Land Cover Types

Before proceeding with the practical session exercise you should display the practical session date set in an Imagine Viewer and attempt to locate areas in the image that represent the broad land cover types present in this scene.  The particular image under investigation in this practical session comprises of quite a complex mixture of land cover types that exhibit a relatively high spatial frequency.  A careful visual analysis of the image and existing map information suggests that approximately 10 distinct land cover types (classes) could be extracted for this scene.  However, the objective of this practical session is to introduce you to the use of Imagine to complete a full classification exercise.  The recognition of 10 classes and their subsequent validation would, for this practical session, be to time consuming.  As such, you should attempt to recognize in the image areas that correspond to the following broad land cover types:

Built1:
areas of consisting of a combination of residential buildings and roads.

Built2:
areas of individual buildings with a different spectral-response than Built1.

Woodland:
areas of substantial trees in the scene.

Arable:
areas in the image that have agricultural crops present.

Pasture:
areas in the image of grassland or fallow land.

Bare Soil:
areas that have no vegetation present (e.g., ploughed fields).

Water:
areas of water bodies – including the sea.
In order to achieve this you should display the original Landsat 5 Thematic Mapper image as either a false colour composite or a true colour composite. Details on how to perform this should be familiar to you by know, but if you have forgotten you can obtain the first practical session hand out from the Geog2750 practical material room, which covered this material.

3. Selecting and Specifying Training Areas in Imagine

Having inspected the practical session data set and recognized areas that correspond to each of the seven land cover types in the scene, the next task involves specifying a training area for each class in order to produce a statistical description of its multispectral distribution.  To start, select from the main Imagine control panel the Classifier->Signature Editor option.  A new dialog window should appear called the Signature Editor.  It is this dialog that you will use to enter the training area for each class. Before proceeding any further ensure that you have the practical session data set displayed in an Imagine Viewer.

In the Signature Editor dialog select the Edit->Image Association option and specify the practical session data set.  This operation ensures that any statistics derived for a class are for the pixel values in the practical session data set.  Next in the image Viewer displaying the practical session data set select AOI->Tools; this should result in a new icon-based window appearing.  It is this tool in association with the Signature Editor that you will use to enter the training areas of each class.

To enter a training area for a class you will need to use the create polygon AOI icon menu option shown below:
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By selecting this icon you can, by using the left mouse button, digitize in the image Viewer the boundary area that corresponds to a particular class that you wish to classify. To complete a polygon for a particular class double left mouse click.  If you are unhappy with the area you have digitized in the viewer you can remove it by selecting the resulting polygon and then selecting the Cut Selected Objects icon show below:
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To actually enter a training area for a class, digitize on the image the area that corresponds to the pixels that are indicative of that class in the image.  Remember that you can use the zoom option to get a precise display of the area you wish to digitize.  Once you have digitized the boundary, select the Create New Signature icon option (shown below) in the Signature Editor window:
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This should result in the first class being specified in the Signature Editor window, as shown below:
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At this stage, you should change the Signature Name to be the actual name of the class you have digitized (e.g., Built1, Built2, Woodland, Arable, Pasture, Bare Soil or Water). Additionally, you may want to change the colour assigned to the class – as this will be the colour it will be displayed as in the final classified image.  To do this for any class, make sure that the indicator arrow of the second column of the Signature Editor class information (>) is set to the class you wish to modify the colour for and then right mouse button in the colour entry for the class of interest.  A range of colours will then be displayed from which you can choose the new colour of the particular class you are editing.  If you wish at any stage to completely remove a class from the Signature Editor, and then select the class in the Class # column and then right-mouse select the Delete Selection option.

You should perform the above procedure for each class that you have to classify for the practical session data set – that is, you should carefully define a single training area for each class and place it in the Signature Editor.  Your resulting Signature Editor should look similar to the one shown below.

[image: image13.png]



Although you have defined a single training area for each land cover type, it is very rare in supervised classification that a single training area per-class is sufficient to express and capture the entire statistical distribution of the themes present in a scene.  Thus, it is normal to specify multiple training areas for each class.  While this is possible in Imagine it is a rather tricky and cumbersome task.  However, the procedure required to do this is outlined below.
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First, define for each class a further training area.  However, for each of these you should rename them to be the class name followed by the digit 2.  For example, if you were creating the second training area for the Woodland class this training area in the Signature Editor should be called Woodland2.  Also you should assign this new training area the same colour as the first one for the class under consideration.  The reason that you need to append the number 2 onto the end of the name of the class is that Imagine requires any new signature (training area) to have a unique name even if it corresponds to the same class in the image.  The result of this procedure should be a Signature Editor similar to the one shown below:

At this stage you now have two training areas for each class, although each with different names and as far as Imagine is concerned they form completely separate classes in terms of the classification of the image.  The next stage, therefore, requires you to combine the two signature entries for each class to explicitly tell Imagine that they correspond to a single class.  Before doing so, however, it may be a good idea to save the signature file as it stands, in case you make a mistake or wish to re-edit it at a latter stage.  Also, in the image Viewer you may want to save the polygonal boundaries of each training class as an AOI layer using the File->Save->AOI Layer As option.  This will allow you to reload the AOI training areas at a latter date for visual inspection, editing and hardcopy printing.

In order to combine the two signatures for single class into a single combined signature entry for that class do the following.  First, left mouse select in the Class # column one of the signature entries for the class you wish to combine.  Next with the shift key on select the next signature entry for that class.  With both selected (shown in yellow) select the Merge Selected Signature icon shown below:
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A new class entry will appear in the signature entry box.  Select this, and give the class a temporary name and change its colour to the colour you wish the class to be displayed in.  Next re-select both signature entries for the combined class you have just created and right-mouse select the Delete Selection option.  This will delete the two original signature entries for the combined class you have just created.  Next select the new combined class and give it its correct name for the class.  You should repeat this procedure for the two signature entries of each class.  Your final signature entry window should now look similar to the one shown before.

You should now save these new combined signatures (one for each class) as a new signature file (with a different name to the one you saved previously).  This can then be reloaded at a latter date for classification purposes.

4. Investigating the Class Statistics

Having generated a combined set of training signatures for each land cover class of interest, the next stage involves assessing how well they characterize the statistical distribution of each class in multispectral feature space.  The Signature Editor offers a number of different means by which this can be achieved.  The simplest means by which to investigate the statistics of each class is to display their mean vector and covariance matrix.  This can be achieved by selecting the Display Statistics icon, shown below:
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This will result in a new window appearing which lists the mean vector and covariance matrix along with other summary statistical information.  By selecting a class row in the (>) column of the Signature Editor the statistics of the particular class selected will be displayed in this new window.  An example of this is shown below for the Woodland class:
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Although careful examination of each class mean vector and associated covariance matrix can give an indication of their suitability and in particular their separability in multispectral feature space, a number of alternative graphical tools can summarize a little easier the information contained in the Statistics window.  The first approach is to display a plot of the means of all classes for all spectral-bands under consideration.  This can be achieved by selecting in the Class # column all classes using SHIFT left-mouse button and then selecting the Display Mean Plot Window option in the Signature Editor, shown below. Within Signature Mean Plot, change to Multiple Signature Mode:
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The result of this process is a new window similar to the one shown below:
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A careful examination of this display should allow us to begin to assess if there are any classes which may exhibit considerable overlap in multispectral feature space and hence may be difficult to clearly separate when applying the chosen supervised classification algorithm.  In the Mean Plot display window shown above, it can be seen that in all spectral-bands there are a number of classes which have means which are close to one another.  This suggests that when their variance is taken into account considerable statistical overlap may exist.  For example, in Band 1 above, class combinations of Water-Built1-Pasture, Built2-Soil and Arable-Wood have similar mean values.  Similar relationships are also evident in the other spectral-bands.   However, it is important to note that the above display does not shown the variance around each class mean for each spectral-band – information which is key if we want to truly assess the statistical separability of the classes.

A visual representation of both class means and their associated variance for each spectral band can be obtained by again selecting all classes in the Signature Editor using SHIFT left-mouse and then selecting the Display Histogram icon option, shown below:
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In the new Histogram Control window that appears select All Selected Signatures and All Bands options. Note: you may need to move each of the histogram plots to see them all on your screen. This will result in the histogram of each class being displayed for each spectral-band – as shown below:
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A close examination of the histograms of each spectral-band will begin to show which classes are likely to overlap statistically in which spectral-bands.  For example, in Band 1 the histograms fail to show at all the Built2 class, as this class is seemingly masked in this spectral-band by the Built1 and Soil classes.  In terms of the classification procedure selected, this suggests that the accurate separation of Built2 from Built1 and Soil is likely to be problematic.  The histogram displays also allow us to check the actual shape of the distribution of each class in each spectral-band.  For example, in Band 3 the Arable class is exhibiting a clear multi-modal distribution and considerable overlap with the Woodland class.  In the case of the latter, this suggests again that the separability between these two classes may be problematic.  However, more importantly, this shows that the Arable class is breaking the key statistical parametric assumption of the maximum likelihood classifier – namely that all classes exhibit a multivariate normal distribution in feature space.  As such, the selection of the maximum likelihood classifier for the classification of these classes, due to the Arable multi-modal distribution in Band 3, should be avoided, unless the training areas for this class are carefully redefined.

The final means by which the class statistics can be investigated is by divergence analysis, which as outlined in the lecture provides a pairwise assessment of the relative separability of each class.  A divergence matrix can be derived from the Signature Editor by selecting the Evaluate->Seprability option. In the dialog window that appears select Transformed Divergence and press OK.  A new window containing the divergence matrix should appear. Classes which exhibit no separability in feature space have a pairwise value of 0, while classes which are essentially completely separable (i.e., exhibit no overlap) have a pairwise value of 2000.  The resulting transformed divergence matrix displayed should look similar to the one shown below:

[image: image21.png]Accuracy Assessment (No file)
Fle Edt View Repot Help

S| #

Point #]_Name. 0 ¥ [ Class [ Reference =





An analysis of the matrix shows that we do indeed have overlap between the training statistics of Built1 and Built2, Built1 and Soil, and Built2 and Soil – indicating further and in this case quantitatively that we may struggle to classify correctly these classes when applying a supervised classification procedure.

At this stage, you should use the tools described above to ensure that you are happy with the visual and quantitative separability of your training classes and that they are exhibiting multivariate normal distributions in feature space.  If you are unhappy with your class separability you will need to return to your original training signatures (saved earlier) and select the problematic classes and then redefine them using the AOI digitizing procedure described above.  Remember, if you have to do this you should not only delete the entries for a problematic class in the Signature Editor but also its digitized boundary in the image Viewer.  Remember also, when you have redefined the class or classes to save both the AOI layer in the Viewer and the Signature entries.  Finally, you will have to perform the signature combination steps again to get your multiple signature entries for a class into a single signature description.

5. Running the Classifier

Once you are entirely satisfied with the separability of your training statistics for the seven broad land cover types, the next stage involves actually running the classification.  This can either be achieved from the Signature Editor by selecting Classify->Supervised option or by selecting the  Classifier->Supervised Classification option from the main Imagine panel.  For the purposes of this exercise you should perform a maximum likelihood classification – the default option.  To do this simply enter the name of the output file you wish to call your classified image and press OK.  Once the classification routine has finished you should display your classified image in a Viewer as a Raster Layer.  In the classified image each class should be displayed using the colour you assigned it in the Signature Editor.

6 Quantifying the Classification Accuracy

The final stage of processing involves evaluating quantitatively the accuracy of your classification.  This involves finding for an independent randomly selected set of pixels the class they belong to using the original image, and then calculating the actual class they have been assigned to in the classified image.  The result of this process is a confusion matrix – which expresses for each class, the number of correctly classified pixels, the number of pixels classified as another class (omission) and the number of pixels which have been assigned to a class but should have been classified as one of the other classes (commission).

It is worth noting at this stage that in order to perform a robust and statistically valid accuracy assessment a considerable independent random sample of pixels is required.  Like many sampling approaches, the general rule of thumb is that the more samples you have the better, although many remote sensing texts suggest that between 1-2% of the total number of pixels in an image is sufficient.  However, even a 1% independent sample for this image will require you to locate and correctly assign a known class to 10,485 pixels (1024 rows*1024 columns/100).  For a proper remote sensing application this is certainly the minimum number of independent test pixels required.  However, the aim of this practical session and the assignment is to introduce you to the classification procedures available in Imagine.  As such, it will be sufficient for demonstration purposes to derive an independent sample of approximately 20 pixels per-class or 140 in total (a number that in reality is far from sufficient to ensure a robust classification accuracy assessment).

In order to perform the accuracy assessment of your classified image you should make sure that you have displayed the original image (wir12345.img).  Select from the Classifier option of the main Imagine panel the Accuracy Assessment option.  A new window should appear as shown below:
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The first stage of the accuracy assessment involves loading the classified image into the Accuracy Assessment tool. Using the File->Open option enter the name of your classified image.  This will be loaded in to the Accuracy Assessment tool BUT will not be re-displayed.  Next you need to specify the image you wish to display the independent random selection of test pixels in  - this should be the original image that you classified.  Select the Select Viewer option icon, shown below:
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When prompted, left-mouse click in the Viewer containing the original image.

The next stage involves the derivation of the random selection of test pixels.  To do this, select the Create/Add Random Points option from the Edit option of the Accuracy Assessment window.  A new dialog should appear.  In this set the Number of Points to be 140 and select the Random option – which attempts to ensure, as far as possible, that an equal number of the random independent test pixels are located for each class in the classified image.  Finally press OK.  If a message window appears stating that is has been unable to find 140 points immediately simply select NO to the continuation prompt and YES to keep the random points already selected.  Once this stage has been completed the Accuracy Assessment window should contain the X & Y coordinates of the independent random test pixels selected.

The main task in accuracy assessment involves specifying for the test pixels selected their actual class in the original image.  You could attempt to do this manually using just the X & Y coordinates. However, by selecting the View->Show All option the actual location of the test pixels along with their ordinal number is displayed in the original image.  You can now, using the zoom option in the Viewer, work systematically through each test pixel in order and assign its true class in the image by visual means and enter its class in the Accuracy Assessment window.  Unfortunately, Imagine does not provide the name of the classes but rather it shows their ordinal class id value. You can find out the class id assigned to each class by noting down the column entry entitled Value in the Signature Editor.  You will need to use these values for each class to assign the actual correct (Reference) class of a test pixel displayed in the image Viewer.

As a tip, you may find it easier and quicker to find the true class of a test pixel by selecting blocks of 5-10 test pixels at a time, displaying just these in the original image and then deriving their true (Reference) class.  This can be achieved by using SHIFT left-mouse button to select 5-10 test pixels sequentially and then specifying the View->Show Current Selection option in the Accuracy Assessment window.  This is shown diagrammatically below:
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For each sequential set of test pixels you should enter their actual class id value (as shown in the Signature Editor Value column) in the Reference column shown above.  Once you have completed this for all your test pixels you can finally evaluate the accuracy of your classification.  To do this, select the Report->Accurcay Report option.  This will result in a confusion matrix (or error matrix as referred to by Imagine) similar to the one below being produced.  Using the lecture 6 material you should be able to interpret the table below.
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NOTE: access the practical session 6 handout at the beginning of Week 8 from the Nathan Bodington Geog2750 practical material room prior to the Week 8 timetabled practical class.  You can download the practical handout to your ISS folder, keep your downloaded practical handout document open or print off a copy for the practical session.
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University of Leeds

Assignment 3
Producing a Land Cover Classification of a Landsat 5 Thematic Mapper Image

Marked out of a total of 30 marks.
Deadline: 2pm Friday 12th November 2004
Name:

Programme:

Deliverable 1 (3 marks): Provide a suitably cropped screen-capture of your classification. By using arrows annotate the class names that correspond to each colour or shade of grey on the final classified image. 

Paste your classified image on this page.
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Deliverable 2 (7 marks): Complete the confusion matrix (error matrix) below for your classified image. You should use the output produced from ERDAS Imagine’s accuracy assessment tool covered in the Section 6 of the assignment hand out and the example confusion matrix in the lecture to aid you in completing your confusion matrix.

Reference Data

	Classified

Data
	
	Built1
	Built2
	Wood
	Arable
	Pasture
	Soil
	Water
	Commission pixels
	Row

total

pixels
	Users

Accuracy %

	
	Built1
	
	
	
	
	
	
	
	
	
	

	
	Built2
	
	
	
	
	
	
	
	
	
	

	
	Wood
	
	
	
	
	
	
	
	
	
	

	
	Arable
	
	
	
	
	
	
	
	
	
	

	
	Pasture
	
	
	
	
	
	
	
	
	
	

	
	Soil
	
	
	
	
	
	
	
	
	
	

	
	Water
	
	
	
	
	
	
	
	
	
	

	
	Omission Pixels
	
	
	
	
	
	
	
	
	
	

	
	Column total
Pixels
	
	
	
	
	
	
	
	
	
	

	
	Producers Accuracy 
% 
	
	
	
	
	
	
	
	
	
	


Overall Accuracy =
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Question 1 (10 marks, 300 words maximum): By displaying and visually analyzing your classified image and the original Landsat 5 Thematic Mapper image, and using your confusion matrix above, provide a critical evaluation of how well you feel your classification has characterized the land cover types present in the Landsat 5 Thematic Mapper image of north west England and North Wales. Your discussion should focus not only on the overall performance but also on individual classes – how well are these classified, how much commission or omission exists with other classes, what are these classes, why do you think this is etc. You should also consider whether the classes you have used are enough to characterize the land cover of the area – are there any classes you would add, if so why and what are they classed as at present, are these sensible etc.
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Question 2 (10 marks): Briefly state and justify 5 actions that would potentially allow a more accurate and rigorous classification to be achieved for the Landsat 5 Thematic Mapper image of north west England and north Wales, compared to the procedure you have adopted in this assignment.
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Answer to Question 2:
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Answer to Question 1:
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REMINDER


I strongly suggest that you go through this practical sheet during the practical class on Wednesday 3rd November and then attempt to address the actual assignment task of performing a rigorous land cover classification of the Landsat 5 Thematic Mapper image. 





Crop tool for cropping unwanted areas from Pictures.
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